Damon's Recent Activity

  1. Damon replied to the thread Electrical Issue with New Motor - Need Help.

    BTW, I did replace the one relay for the ignition/system with a new one, but it did not solve any issues. Therefore, I don't think the...

    Sep 20, 2019 at 11:00 PM
  2. Damon replied to the thread Electrical Issue with New Motor - Need Help.

    UPDATE: Determined that the purple ignition wire was turning the ignition on, and the thicker red/purple striped wire was providing...

    Sep 20, 2019 at 10:41 PM
  3. Damon attached a file to the thread Electrical Issue with New Motor - Need Help.

    I’m replacing the stupid OEM Mercury plugs: [ATTACH] With these little monkeys: [ATTACH]

    C816759C-5034-4AC8-8099-36799917DFE3.jpeg upload_2019-9-20_12-16-4.jpeg Sep 20, 2019 at 3:16 PM
  4. Damon replied to the thread Electrical Issue with New Motor - Need Help.

    The plug and pins looked very clean on both relays and ECM. However, one of the relays had a faint order similar to what we smelled when...

    Sep 20, 2019 at 11:59 AM
  5. Damon posted a new thread.

    Electrical Issue with New Motor - Need Help

    It has been a while since I've been on this site. Since we launched the boat in March after the repower, we have logged 230 hours on...

    IMG_0726.jpg IMG_0772.jpg IMG_0789.jpg IMG_0806.jpg IMG_0807.jpg IMG_0821.JPG IMG_0786.jpg IMG_0825.jpg 20107.png 35498.gif

    Forum: Mechanic's Corner

    Sep 19, 2019 at 7:23 PM
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.